Follow

Is there a preferred browser to use?

Pointman works best with Google Chrome and Safari. 

We recommend primarily using Google Chrome, but Safari will work as well. If you are using another browser such as FireFox or Edge, you may experience issues that will decrease the overall experience of using Pointman.

**NOTE**
You'll wan to be sure that if you're using a pop-up blocked on your browser, that you have it disabled for Pointman.

If you require further assistance, please reach out to the Support Team using any of our channels - 

Phone: 800-566-6940.

Chat with us!

Powered by Zendesk